Agilent OpenLAB
Chromatography Data System (CDS)

Workstation Installation and Configuration Guide
Notices

© Agilent Technologies, Inc. 2010-2013, 2014

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number
M8301-90007

Edition
09/2014

Printed in Germany
Agilent Technologies
Hewlett-Packard-Strasse 8
76337 Waldbronn

This product may be used as a component of an in vitro diagnostic system if the system is registered with the appropriate authorities and complies with the relevant regulations. Otherwise, it is intended only for general laboratory use.

Software Revision
This guide is valid for revision A.02.02 or higher of Agilent OpenLAB CDS

Microsoft ® and Windows Server ® are U.S. registered trademarks of Microsoft Corporation.

Warranty
The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses
The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend
If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015(b)(2) (November 1995), as applicable in any technical data.

Safety Notices

CAUTION
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING
A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

CDS Workstation Installation and Configuration Guide
This installation guide is designed to help system administrators install the Agilent OpenLAB Chromatography Data System (CDS) workstation.

**Table 1**  Terms and abbreviations used in this document

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChemStation</td>
<td>OpenLAB CDS ChemStation Edition</td>
</tr>
<tr>
<td>EZChrom</td>
<td>OpenLAB CDS EZChrom Edition</td>
</tr>
<tr>
<td>ECM</td>
<td>OpenLAB Enterprise Content Manager</td>
</tr>
<tr>
<td>Data Store</td>
<td>OpenLAB Data Store</td>
</tr>
<tr>
<td>AIC</td>
<td>Agilent Instrument Controller</td>
</tr>
</tbody>
</table>

1 **Introduction**

This chapter gives you an overview of the OpenLAB CDS software. It also includes certain requirements before starting the installation.

2 **Configure your Workstation PC**

Agilent-delivered PC Bundle systems are delivered with the supported pre-installed Windows operating system and are configured for optimum performance. Non-Agilent PC Bundle systems require some manual configuration changes in order to provide optimum performance. This chapter describes how to configure a non-Agilent PC Bundle system.

3 **Install the Software**

The installation is automated by the OpenLAB CDS Master Installer. This tool installs the various components of OpenLAB CDS.

4 **Scripted Installation**

This chapter describes the syntax and parameters for an installation or uninstallation in command line mode.
5 Optional Procedures

This chapter describes the installation of OpenLAB Data Analysis as an add-on or standalone application. It also contains information on the Additional Drivers and Software wizard, the Software Verification Tool, and the upgrade of an OpenLAB CDS Workstation.

6 Uninstall the Software

This chapter contains information on the uninstallation by using the OpenLAB CDS Uninstallation Wizard. It also describes post uninstallation tasks that are essential if you plan to reinstall ChemStation on the same computer.
Contents

1 Introduction 7
   Who Should Read This Guide? 8
   The Agilent OpenLAB CDS Software 9
   Before You Begin 10

2 Configure your Workstation PC 13
   About Configuration 14
   Installing Windows 15
   Using the OpenLAB CDS Configuration Checker 16
   Configuring Windows 7 17
   Configuring Windows 8.1 23
   Configuring the Antivirus Program 27
   Editing the Security Settings for LC/MS and CE/MS Systems 29

3 Install the Software 31
   Step 1: Run the Application 32
   Step 2: Copy DVDs to a Centralized Folder for Installation (Optional) 33
   Step 3: Run the System Configuration Checker 34
   Step 4: Prepare Third Party Tools 35
   Step 5: Run the OpenLAB CDS Installation Wizard 36
   Post Installation Tasks 42
   What to do Next 44

4 Scripted Installation 47
   About Scripted Installation 48
   Export as XML 49
   Parameters and Return Codes 50
   Installation, Upgrade, or Repair 53
   Uninstallation 54
   Logging and Tracing 54
Contents

5 Optional Procedures  55
Install OpenLAB Data Analysis as Add-on or Stand-alone Application  56
Install Additional Software and Drivers  59
Run a Software Verification after Software Installation  60
Upgrade OpenLAB CDS Workstation to Latest Version  61
Transform a Workstation to a Networked Workstation  65

6 Uninstall the Software  67
About Uninstallation  68
Run the Master Installer  69
Run the OpenLAB CDS Uninstallation Wizard  70
1 Introduction

Who Should Read This Guide? 8
The Agilent OpenLAB CDS Software 9
Before You Begin 10

This chapter gives you an overview of the OpenLAB CDS software. It also includes certain requirements before starting the installation.
Who Should Read This Guide?

This installation guide is designed to help system administrators and other users install the Agilent OpenLAB Chromatography Data System (CDS) to individual workstations quickly and correctly.

Figure 1  Workstation configuration
The Agilent OpenLAB CDS Software

The Agilent OpenLAB CDS, along with OpenLAB Enterprise Content Manager (ECM) and OpenLAB Data Store plus several add-ons make up the Agilent OpenLAB software suite.

The Agilent OpenLAB CDS software suite is designed to grow with customers' needs, from a small standalone analytical lab to a global network with hundreds of locations. Using the OpenLAB software, instruments from multiple vendors can connect to any size network — from individual workstations and workgroups to global enterprises. With full instrument control, centralized administration and ease-of-support, users can achieve lower operational costs and better instrument use. See your Agilent representative to learn how other products in the OpenLAB suite can help you.

The Agilent OpenLAB CDS software is provided on DVDs. The following table lists the disks you will receive for your software edition.

**Table 2**  
OpenLAB CDS Components

<table>
<thead>
<tr>
<th>Disk Name</th>
<th>ChemStation Edition</th>
<th>EZChrom Edition</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenLAB Shared Services Software</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>OpenLAB CDS ChemStation Edition Core</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Software</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OpenLAB CDS ChemStation Edition Drivers</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>OpenLAB CDS EZChrom Edition Core</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Software</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OpenLAB CDS EZChrom Edition Drivers</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>OpenLAB Support &amp; Utilities</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>OpenLAB Data Analysis^{1}</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

^{1} Only supported with an OpenLAB CDS Workstation, or with OpenLAB CDS EZChrom systems using an Enterprise Path without Advanced File Security.
Before You Begin

To simplify installation of the software, it is helpful to decide on some configuration options before you begin the actual software installation.

1 For installing OpenLAB CDS, you need to have administrator privileges for all servers and clients. Power user privileges are not sufficient (the installation does not start).

2 Decide on a directory location to store all files related to the data system software, including data, methods, sequences, and configurations. The directory must always be accessible to the PC running the software.

3 If you will be using OpenLAB ECM with your system, obtain the ECM server name.

4 Decide on the software delivery approach you want to use:
   - *Install directly from the DVDs to your computer* — Load the disks as required directly to the workstation disk drive. (Recommended)
   - *Copy DVDs to a centralized location for installation* — You can use the utility to copy DVD content to a network share folder or USB drive, and run an uninterrupted installation from that location. This approach will save time; when you install from the folder, you won’t have to reload the disks. However, some networks may interfere with installation.

5 Remember that when you launch the application, you will be able to review the following PDFs in the installer **Planning** and **Resources** menus before you install the software.

**NOTE**

Make sure you have administrator privileges for both ECM and OpenLAB.
Under the **Installer Planning** menu, you will find:

- *OpenLAB CDS Hardware and Software Requirements* — Use this PDF to determine whether your hardware and software will support the system.

- *Workstation Installation Guide* — An electronic copy of this installation guide is provided in PDF format for your convenience.

Under the **Installer Resources** menu, you will find:

- *OpenLAB CDS Network Requirements* — Use this PDF to check that your settings comply with the network requirements.

6 Install all required hardware, including any A/D boards, cables, GPIB interfaces, instrument detectors, and communication cables.
1 Introduction
   Before You Begin
2 Configure your Workstation PC

About Configuration 14
Installing Windows 15
Using the OpenLAB CDS Configuration Checker 16
Configuring Windows 7 17
Configuring Windows 8.1 23
Configuring the Antivirus Program 27
Editing the Security Settings for LC/MS and CE/MS Systems 29
  Firewall 29
  Advanced Network Settings 29

Agilent-delivered PC Bundle systems are delivered with the supported pre-installed Windows operating system and are configured for optimum performance. Non-Agilent PC Bundle systems require some manual configuration changes in order to provide optimum performance. This chapter describes how to configure a non-Agilent PC Bundle system.
About Configuration

Some changes within this document are mandatory for OpenLAB CDS to work properly on a Windows system. Some changes will optimize application performance. Other changes will have a graphical or minor impact.

**NOTE**

To indicate the relative importance of individual settings, each item is categorized as:

**MUST:** These changes must be applied.

**PERFORMANCE:** These changes will improve system performance.

**OPTIONAL:** Most of these changes will affect the graphical display of the application.

**NOTE**

If User Account Control (UAC) is switched on, some configuration steps will require active confirmation to continue.
Installing Windows

1. Install Windows from the Microsoft installation media. During the setup, provide the computer name, administrator password and network settings. Choose to either join an existing domain or set up the system in a workgroup mode.

2. To secure your system against viruses please install an antivirus program. Be sure to open the firewall ports listed in the Firewall Settings in the OpenLAB CDS Network Requirements guide.

NOTE
Keep your PC disconnected from the internet until you have installed the appropriate security patches and hot fixes. It is strongly recommended to install the latest security fixes as supported from Agilent Technologies and virus definitions prior to connecting to a network.

NOTE
Running antivirus programs might influence the behavior and performance of your computer. Some virus scanners might cause issues when used with OpenLAB CDS. OpenLAB CDS was tested to run with Symantec’s Endpoint Protection.
Using the OpenLAB CDS Configuration Checker

The OpenLAB CDS Configuration Checker checks and repairs all mandatory settings. It does not check optional settings or settings that improve the performance.

The OpenLAB CDS Configuration Checker comes as .diagcab file, which is a file format used with the Microsoft Windows Troubleshooting Platform (WTP) program. The Microsoft Windows Troubleshooting Platform (WTP) is a platform to locate and fix hardware and software settings in Windows. It is used specifically for diagnosing and repairing computer settings.

In general, .diagcab files are useful for deploying troubleshooting packs because they are self-contained and require no installation. They can be deployed onto web sites, network shares, or copied to USB keys. The .diagcab file name extension is a registered file name extension that can be executed by WTP.

To start the OpenLAB CDS Configuration Checker, call the file Agilent.Wtp.ChemStation.WindowsConfiguration.diagcab. This file is located on the OpenLAB CDS disc 6 under Tools\OpenLAB CDS ChemStation Edition\Diagnostics\WindowsConfiguration\Cab\n
While using the Configuration Checker:

- Ensure that this computer is not turned off by another user.
- Ensure that the menu bar is enabled.
Configuring Windows 7

[MUST] 1 Go to Start > Control Panel > System\(^1\), and register Windows with Microsoft.

[MUST] 2 Folder Options (Go to Start > Control Panel > Folder Options): In the View tab,
   - Clear Hide extensions for known file types.
   - Enable Display the full path in the title bar.
   - Clear Use Sharing Wizard.

[MUST] 3 Check for updates and apply all critical security patches (Go to Control Panel > Windows Update):
   Click Check for updates.

[MUST] 4 Settings for updates (Go to Control Panel > Windows Update):
   Click Change settings. In the Important updates section, select Never check for updates. Clear the other update options.

**NOTE**
This setting is important to avoid data loss due to system reboot during data acquisition.

[MUST] 5 Disable Services (Go to Control Panel > Administrative Tools):
   a Double-click Services.
   b Double-click the following services and set their startup type to Disabled:
      - Application Experience
      - Desktop Window Manager Session Manager

[MUST] 6 Disable indexing (Go to Control Panel > Indexing Options):
   Click the Modify button. Clear all drives and locations.

\(^1\) View the items by icon to see a list of all items.
2 Configure your Workstation PC

Configuring Windows 7

7 Windows logon options (Start > search for 'gpedit.msc')


b Set Hide entry points for Fast User Switching and Always use classic logon to Enabled.

[MUST] 8 Adjust Power Options (Go to Control Panel > Power Options):

a As preferred plan select High performance

b Click Change Plan settings

c Set the option Put the computer to sleep to Never.

d Click Change advanced power settings.

e Open the nodes for Hard disk > Turn off hard disk after.

f Set the Minutes to 0 (=Never).

[MUST] 9 Local Security Policy: (Go to Control Panel > Administrative Tools):

a Double-click Local Security Policy.

b Navigate to Security Settings > Local Policies > Security Options

c Double-click the following policy listed in the right hand panel: Network Access: Sharing and security model for local accounts

d In the displayed dialog select the following item from the drop-down list: Classic - local users authenticate as themselves

[MUST] 10 Region and Language (Go to Control Panel > Region and Language).

a Regional options should be set to English (United States) from the drop-down list.

b If regional format other than English (United States) is used, the following settings are mandatory. The settings can be defined by clicking on the Additional settings... button:

- Decimal symbol = . (point)
- Digit grouping symbol = , (comma)
- List separator =, (comma)

[MUST] 11 Time Zone (Go to Control Panel > Date and Time): Choose the time zone of your machine's location.
[MUST] 12 Power Management for network devices (Go to Control Panel > Network and Sharing Center):
   a Select Change adapter settings. Right-click Local Area Connection > Properties > Configure.
   b On the Power Management tab, clear all check boxes.

[MUST] 13 Enable non-http activation (Go to Control Panel > Programs and Features):
   a Click Turn Windows features on or off.
   b Expand the Microsoft .NET Framework 3.5.1 node and select the Windows Communication Foundation Non-HTTP Activation check box.

[MUST] 14 Disable Compatibility View in Internet Explorer.

   a Open Internet Explorer.
   b Click the Tools menu, and then click Compatibility View Settings.
   c Clear the Display intranet sites in Compatibility View check box.

[PERFORMANCE] 15 Performance options (Go to Control Panel > System):
   a Click Advanced system settings.
   b On the Advanced tab > Performance click Settings.
   d Save the settings.

NOTE This step is only required if you use OpenLAB Data Store.
Configure your Workstation PC
Configuring Windows 7

[PERFORMANCE] 16 System Properties (Go to Control Panel > System):

a  Click Advanced system settings.

b  On the Advanced tab > Performance click Settings.

   - Advanced tab > Virtual Memory: For optimum performance use the Change button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible locate the paging file on a drive different from system and ChemStation installation drive.

   - Data Execution Prevention tab: Select Turn on DEP for essential Windows programs and services only.

c Advanced > Startup and Recovery > Settings button:

   - System startup section:
     Change both Time to display ... fields from 30 to 3 sec.

   - System failure section:
     Select Automatically restart, in the Write debugging information section select Kernel memory dump from the drop-down list.

d Remote tab

   - In the Remote Assistance section, clear the check box Allow Remote Assistance connections to this computer.

   - In the Remote Desktop section, select Don't allow connections to this computer.
General Layout: (right-click Start > Properties)

a. Start Menu Tab: In the Privacy section select both items

b. Start Menu Tab > Customize button: In Customize Start Menu dialog:
   - Clear the following option:
     - Favorites menu
   - Select the following options:
     - Computer Display as a link
     - Connect To
     - Control Panel: Display as a menu
     - Default Programs
     - Devices and Printers
     - Documents: Display as a link
     - Enable context menus and dragging and dropping
     - Games: Don't display this item
     - Help
     - Highlight newly installed programs
     - Music: Don't display this item
     - Network
     - Open submenus when I pause on them with the mouse pointer
     - Personal folder: Display as a link
     - Pictures: Display as a link
     - Run command
     - Search other files and libraries Search with public folders
     - Search programs and Control Panel
     - Sort All Programs menu by name
     - System administrative tools: Display on the All Programs menu and in the Start menu
     - Use large icons
2 Configure your Workstation PC
Configuring Windows 7

[OPTIONAL] 18 Welcome Center (Start > search for 'gpedit.msc'):
   a Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.
   b Set Don’t display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 19 Recycle Bin Properties: (right-click on desktop icon Recycle Bin) Select the following options:
   • Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
   • Select Display delete confirmation dialog.
Repeat these steps for all drives of your computer.

[OPTIONAL] 20 Language for non-Unicode programs (Go to Control Panel > Region and Language): On the Administrative tab, click Change system locale.... From the drop down list, select English (United States)

NOTE Do not change system locale if you are using an English, Japanese or Chinese Operating System.
Configuring Windows 8.1

[MUST] 1 Go to Start > Control Panel > System, and register Windows with Microsoft.

[MUST] 2 Folder Options (Go to Start > Control Panel > Folder Options): In the View tab,
   - Clear Hide extensions for known file types.
   - Enable Display the full path in the title bar.
   - Clear Use Sharing Wizard.

[MUST] 3 Check for updates and apply all critical security patches (Go to Control Panel > Windows Update):
   Click Check for updates.

[MUST] 4 Settings for updates (Go to Control Panel > Windows Update):
   Click Change settings. In the Important updates section, select Never check for updates. Clear the other update options.

NOTE

This setting is important to avoid data loss due to system reboot during data acquisition.

[MUST] 5 Disable Services (Go to Control Panel > Administrative Tools):
   a Double-click Services.
   b Double-click the Application Experience service. Set the startup type to Disabled.

[MUST] 6 Disable indexing (Go to Control Panel > Indexing Options):
   Click the Modify button. Clear all drives and locations.

1 View the items by icon to see a list of all items.
[MUST] 7 Adjust Power Options (Go to Control Panel > Power Options):
   a As preferred plan select **High performance**
   b Click **Change Plan settings**
   c Set the option **Put the computer to sleep** to **Never**.
   d Click **Change advanced power settings**.
   e Open the nodes for **Hard disk > Turn off hard disk after**.
   f Set the Minutes to 0 (=Never).

[MUST] 8 Local Security Policy: (Go to Control Panel > Administrative Tools):
   a Double-click **Local Security Policy**.
   b Navigate to **Security Settings > Local Policies > Security Options**
   c Double-click the following policy listed in the right hand panel: **Network Access: Sharing and security model for local accounts**
   d In the displayed dialog select the following item from the drop-down list: **Classic - local users authenticate as themselves**

[MUST] 9 Region settings (Go to Control Panel > Region).
   a Regional options should be set to **English (United States)** from the drop-down list.
   b If regional format other than **English (United States)** is used, the following settings are mandatory. The settings can be defined by clicking on the **Additional settings...** button:
      - Decimal symbol = . (point)
      - Digit grouping symbol = , (comma)
      - List separator = , (comma)

[MUST] 10 Time Zone (Go to Control Panel > Date and Time): Choose the time zone of your machine's location.

[MUST] 11 Power Management for network devices (Go to Control Panel > Network and Sharing Center):
   a Select **Change adapter settings**. Right-click **Local Area Connection > Properties > Configure**.
   b On the **Power Management** tab, clear all check boxes.
[MUST] 12.NET settings (Go to Control Panel > Programs and Features):
   a Click Turn Windows features on or off.
   b Enable .NET 3.5 by selecting the .NET Framework 3.5 (includes .NET 2.0 and 3.0) check box.

   This option requires an internet connection.

   NOTE
   If the computer has no internet access, .NET Framework 3.5 will not install. For more details see http://support.microsoft.com/kb/2785188.

   c To make sure that all the net.tcp components are properly initialized, non-http activation must be enabled. Expand the .NET Framework 3.5 (includes .NET 2.0 and 3.0) node and select the Windows Communication Foundation Non-HTTP Activation check box.

[MUST] 13 Disable Compatibility View in Internet Explorer.

   a Open Internet Explorer.
   b Click the Tools menu, and then click Compatibility View Settings.
   c Clear the Display intranet sites in Compatibility View check box.

   NOTE
   This step is only required if you use OpenLAB Data Store.

   a Click Advanced system settings.
   b On the Advanced tab > Performance click Settings.
   d Save the settings.

[PERFORMANCE] 14 Performance options (Go to Control Panel > System):

[PERFORMANCE] 15 System Properties (Go to Control Panel > System):
   a Click Advanced system settings.
   b On the Advanced tab > Performance click Settings.
      - Advanced tab > Virtual Memory: For optimum performance use the Change button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible locate the paging
Configure your Workstation PC
Configuring Windows 8.1

- Data Execution Prevention tab: Select Turn on DEP for essential Windows programs and services only.

- Advanced > Startup and Recovery > Settings button:
  - System startup section:
    - Change both *Time to display...* fields from 30 to 3 sec.
  - System failure section:
    - Select Automatically restart, in the Write debugging information section select Kernel memory dump from the drop-down list.

- Remote tab
  - In the Remote Assistance section, clear the check box Allow Remote Assistance connections to this computer.
  - In the Remote Desktop section, select Don't allow connections to this computer.

[OPTIONAL] 16 Welcome Center (*Start > search for 'gpedit.msc'*):

  - b Set Don't display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 17 Recycle Bin Properties: (right-click on desktop icon Recycle Bin) Select the following options:
  - Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
  - Select Display delete confirmation dialog.

Repeat these steps for all drives of your computer.

[OPTIONAL] 18 Language for non-Unicode programs (Go to Control Panel > Region): On the Administrative tab, click Change system locale.... From the drop down list, select English (United States)

**NOTE**
Do not change the system locale if you are using an English, Japanese or Chinese Operating System.
Configuring the Antivirus Program

Be sure to open the firewall ports listed in the Firewall Settings in the OpenLAB CDS Network Requirements guide.

NOTE
Some virus scanners might cause issues when used with OpenLAB CDS. OpenLAB CDS was tested to run with Symantec's Endpoint Protection.

In order for the OpenLAB software to function correctly, you should configure any antivirus real time protection software with the following list of folder exclusions. These folders should only be scanned while the instruments are idle and no data acquisition takes place. Refer to your specific antivirus software documentation on how to configure folder exclusions.

NOTE
The following sections contain general information and also specific details only applicable for OpenLAB CDS ChemStation Edition (e.g. the chem32 folder).

- C:\chem32, D:\chem32, etc.
- C:\programdata\agilent
- %programfiles%\agilent
- %programfiles(x86)%\agilent
- %programfiles%\common files\agilent
- %programfiles(x86)%\common files\agilent
- %programfiles%\agilent technologies
- %programfiles(x86)%\agilent technologies
- %programfiles%\common files\agilent technologies
- %programfiles(x86)%\common files\agilent technologies
- %programfiles%\common files\agilent shared
- %programfiles(x86)%\common files\agilent shared
## Configure your Workstation PC

### Configuring the Antivirus Program

If your antivirus software includes program or executable deny execution settings, ensure that the following program files are not denied execution. You can use the Windows search feature to find the specific folder each program file is located in.

<table>
<thead>
<tr>
<th>Process</th>
<th>Directory</th>
<th>File name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECM upload/download (if applicable)</td>
<td>%temp% for Windows users (=Users' temp directory)</td>
<td>*.ssizip</td>
</tr>
<tr>
<td>Standard reports</td>
<td>%temp% for Windows users (=Users' temp directory)/chem32/core</td>
<td>~p3d*.tmp, ~job*.tmp, Hpspl00.que</td>
</tr>
<tr>
<td>CDS intelligent reports</td>
<td>%LOCALAPPDATA% %APPDATA% %PROGRAMDATA%</td>
<td>Files on:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Agilent</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Agilent Technologies</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Agilent_Technologies._Inc</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• IsolatedStorage</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Temp</td>
</tr>
<tr>
<td></td>
<td></td>
<td>e.g.: C:\Users\xxxxx\AppData\Local\Agilent Technologies\Intelligent Reporting\RawDataFileCache</td>
</tr>
</tbody>
</table>

Depending on your specific configuration, some of the listed folders or files may not exist on your system.
Editing the Security Settings for LC/MS and CE/MS Systems

The following sections summarize all security settings required for LC/MS and CE/MS. All other security settings are set automatically by the OpenLAB CDS Master Installer.

OpenLAB CDS needs to be installed using an operating system Administrator user account. To run the system with the configured options outlined in this document, all users and power users should use the same settings.

Firewall

On PCs controlling LC/MS or CE/MS systems, it is recommended to turn off the firewall.

Advanced Network Settings

The communication with the MS is sensitive to the order NICs in the Adapters and Bindings dialog.

1 Go to Start > Control Panel.

Go to Network and Sharing Center.

2 Click Change adapter settings.

3 Press ALT to bring up the menu.

View the items by icon to see a list of all items.
2 Configure your Workstation PC
Editing the Security Settings for LC/MS and CE/MS Systems

4 Select **Advanced Settings**....

![Advanced Settings dialog, Adapters and Bindings tab](image)

**Figure 2** Advanced Settings dialog, Adapters and Bindings tab

5 In the **Adapters and Bindings** tab (see Figure 2 on page 30):
   a Make sure that the Local Area Connection pertaining to the LC/MS or CE/MS NIC is the first item in the list of connections

**NOTE**

The names of your LAN cards may differ from those shown in the example. You can tell which LAN card is the Instrument LAN by comparing the IP addresses assigned to the LAN cards.

The LAN pertaining to the company intranet > internet will typically have an IP address assigned by organizations Static IP policy or by a DHCP server. Check with your network administrator.
3

Install the Software

Step 1: Run the Application 32
Step 2: Copy DVDs to a Centralized Folder for Installation (Optional) 33
Step 3: Run the System Configuration Checker 34
Step 4: Prepare Third Party Tools 35
    Install Adobe PDF Reader 35
Step 5: Run the OpenLAB CDS Installation Wizard 36
    License Agreement Screen 36
    Installation Folder Screen 37
    Installation Type Screens 37
    Summary Screen 40
Post Installation Tasks 42
    Enable Non-Http Activation 42
    Use Network Locations as Enterprise Path 42
What to do Next 44
    OpenLAB Shared Services Configuration 44

The installation is automated by the OpenLAB CDS Master Installer. This tool installs the various components of OpenLAB CDS.
Step 1: Run the Application

To run the application for the first time on your workstation:

1. For the direct DVD approach, insert the OpenLAB CDS Installation disk (Disk1). The Planning screen starts automatically after inserting the DVD. If the installer is not launched automatically, run Autorun.inf to open this screen.

2. For the portable data storage device approach, insert the device in a computer USB port, navigate to \Disk1\Setup.bat and run the application to proceed to the Planning screen.

3. For the share file approach, copy all DVDs to a centralized folder as described in Step 2 below.
Step 2: Copy DVDs to a Centralized Folder for Installation (Optional)

Completing this step will enable you to run an uninterrupted installation directly from a folder—i.e., you will not have to load individual disks during actual installation.

1 From the Master Installer Planning screen, select Installation from the sidebar menu.

2 Select Preparation of an Installation from Network Share.

3 At the Network Share screen, browse to a directory and create a destination folder as follows:

   a Select the button with the three dots.
   b Navigate to the directory where you want to create the folder (you can navigate to a USB drive port to create the folder on a USB drive).
   c Select Make New Folder.
   d Type in the folder name.
   e Select OK. The system will return you to the Network Share screen, with the path displayed.
   f Select the disks you want to copy to the folder: All disks, ChemStation disks, EZChrom disks, or OpenLAB Data Analysis disks.
   g Select Start.
   h Follow the prompts to insert new disks as they appear.

4 When processing is complete, copy the files to the local drive or map the location to a network drive.

5 Close the application and navigate to the directory and folder you created. Open the folder.

6 Select the Disk1 folder, then execute Setup.bat to run the application. The system will display the installer Planning screen.

**NOTE**
Installations into the root of a drive may cause problems during operations and are not supported.
Step 3: Run the System Configuration Checker

1. At the **Planning** screen, select **System Configuration Checker**.

2. The **Site Preparation Tool** opens. Select the correct edition and setup of the OpenLAB CDS software you are installing from the drop-down list:
   - OpenLAB CDS ChemStation Edition C.01.XX
   - OpenLAB CDS EZChrom Edition A.04.XX
   - OpenLAB Data Analysis A.02.XX

3. Select **OK**.

4. Complete page 1 of the **Contact Information—System details** by typing in the fields provided.
   - System Location fields
   - System Information fields
   - Configuration fields

5. Review the system details and make any necessary entries. The system will follow the paths specified.

6. Select the green check mark icon in the top left corner of the screen to begin the software check. A summary report is displayed showing the results for each check category. Results are expressed as **Pass**, **Warning**, **Critical Warning**, or **Fail**.

   **Fail** results must be corrected before continuing with the installation. Agilent recommends investigating and correcting any **Critical Warnings** and **Warnings** whenever possible before proceeding.

   **NOTE** If the firewall is controlled by security software, the Site Preparation Tool cannot read the firewall settings because of security limitations. As a consequence, the Site Preparation Tool will display **Status "Fail"** for the firewall settings.

   In this case, make sure the firewall is disabled and enter the status in the Site Preparation Tool report manually.

7. To view details of the report, select the appropriate link: **System Hardware Details**, **Operating System and Software Details**, or **Manual Verification Required**.
To save the report, select the **Save** icon at the top left of the screen.

E-mail the saved report to your Agilent Service Representative for evaluation, and for validation of your personal computer for Agilent Software Systems Installs.

---

**Step 4: Prepare Third Party Tools**

The **OpenLAB CDS Master Installer** offers a list of tools that can be installed directly from the **Installation** screen.

**Install Adobe PDF Reader**

You need *version 11* of Adobe PDF Reader to ...

- view site prep or administrative reports (such as system reports)
- use the **Report Viewer** feature (ChemStation Edition only)
- view Software Verification Reports

If Adobe PDF Reader is not installed on your system, or if an older version is installed:

1. Select **Third Party Tools** and then **Adobe PDF Reader**.
   a. The Adobe Reader setup screen appears. Click **Install** to continue.
   b. If Adobe Reader was successfully installed, click **Finish** to exist the setup screen.

Alternatively, you can install Adobe Reader version 11 from the OpenLAB CDS installation DVDs. It is available on Disk1/Tools/Adobe Reader in four language versions (English, Japanese, Chinese and Portuguese).

Run the self-extracting exe-file of your choice and follow the instructions of the Adobe Reader XI Setup wizard.

**NOTE**

If you install Adobe PDF Reader directly from the DVDs: When OpenLAB CDS users open a PDF file for the first time, they will be asked to confirm the Adobe Reader license agreement. This dialog will appear for each newly configured instrument.
3 Install the Software
Step 5: Run the OpenLAB CDS Installation Wizard

Step 5: Run the OpenLAB CDS Installation Wizard

At this point, you’ll either be running your installation using the DVDs directly, or from a centralized location (USB drive or share folder). The installation steps are identical, until you start the installation wizard: *you won’t be prompted to load the DVDs if you are installing from a centralized location.*

License Agreement Screen

1 From the OpenLAB CDS Master Installer screen, select **Installation**.
2 Select **OpenLAB CDS**.
3 The **OpenLAB CDS Installation Wizard** opens. Read the terms of the **License Agreement**. Master Installer provides a printable PDF of the license agreement under the **Resources** option of the main menu.
4 Select **I agree with the terms and conditions**. You cannot proceed with installation unless you agree to these terms.
5 Select **Next** to proceed to the **Installation Folder** screen.
Installation Folder Screen

1. Type the folder name or browse to the directory where you want to store the application components. Folders must have English names.

NOTE

Installations into the root of a drive may cause problems during operation and are not supported.

2. To run an installation verification as part of this installation, select Run Software Verification. The Software Verification Tool provides documentary evidence that your system has been built and installed correctly, and that all design specifications have been met. You can run the Software Verification Tool at a later time if you prefer (see “Run a Software Verification after Software Installation” on page 60).

3. Select Next to proceed to the Installation type screen.

Installation Type Screens

1. Under Installation Type, select Standalone Workstation.

2. Select Next to proceed to the CDS Edition screen. Select the edition of your data system.

3. Select Next to proceed to the installation screens specific to your edition.
3 Install the Software
Step 5: Run the OpenLAB CDS Installation Wizard

4 Choose the CDS edition you wish to install.
   a If you have chosen OpenLAB CDS ChemStation Edition as your edition:
      · Under Installation folder, type the folder name or browse to the directory where you want to store the application components. Folder names must be entered without spaces.

   NOTE ChemStation may not be installed into the same directory as the OpenLAB CDS Shared Server Core.

   · Select the Install OpenLAB Data Analysis check box if you want to install this application in addition to your CDS edition. OpenLAB Data Analysis can be installed as add-on version at a later time if you prefer (see “Install OpenLAB Data Analysis as Add-on or Stand-alone Application” on page 56).

   NOTE OpenLAB Data Analysis is not supported for installations with ECM or Data Store as central data storage.

   · Select the Install IO Library check box if you want to install the Agilent IO library suite. The suite can be installed manually at a later time if you prefer.

   b If you have chosen OpenLAB CDS EZChrom Edition as your edition:
      · Select the Install OpenLAB Data Analysis check box if you want to install this application in addition to your CDS edition. OpenLAB Data Analysis can be installed as add-on version at a later time if you prefer (see “Install OpenLAB Data Analysis as Add-on or Stand-alone Application” on page 56).

   NOTE OpenLAB Data Analysis is not supported for installations with ECM or Data Store as central data storage.

   · Confirm the installation of the print server.
5 Select **Next** to proceed to the **Additional items** screen.

6 If you have not selected the **Install OpenLAB Data Analysis** check box, you have different data storage options. If you want to use **OpenLAB ECM** with your data system:

   a Check the **ECM Server** option button. Type in a server name and press the **Test Connection...** button.

   b The system will perform a connectivity check to verify access to a functional OpenLAB ECM server. If the connectivity check is successful, the message **Connection succeeded** appears. Click **OK** to continue. If the connectivity test fails, you will be returned to the **Additional items** screen. From here you can select **Next** to run the test again. If the test is still unsuccessful:

   - Enter a new OpenLAB ECM server and try another test.
   - Call internal support for assistance if you cannot connect to an OpenLAB ECM server.
   - You can uncheck the box and run the installation without OpenLAB ECM at this time. You will be able to add it to your data system at a later time, when a server is determined.

**NOTE**

The storage type **Data Store Server** is only available for a Networked Workstation or a Distributed System.

7 Select **Next** to proceed to the **Summary** screen.
Install the Software
Step 5: Run the OpenLAB CDS Installation Wizard

Summary Screen

1 Review the installation settings that you have selected in the preceding steps. Select Back as necessary to change installation settings, or Cancel to cancel the installation.

NOTE Before starting or canceling the installation, you can save an XML file with your installation settings. This XML can then be used for a scripted installation (see “About Scripted Installation” on page 48).

2 Select Start to begin installation.

If OpenLAB CDS has been installed and uninstalled before, a warning will be shown that the system detected existing OpenLAB Shared Services database files. You can either:

- Click Yes to create new database files.
- Click No to reuse existing database files.

3 The system performs an automated system check before it proceeds with the listed activities.

If a system check passed message appears, installation continues.

If a system check failed message appears, you can either:

- Decline to view the system report, and continue installation.
- View the system report, and decide to continue installation.
- View the system report and postpone installation until the problem is fixed.

NOTE To view the system report as PDF file, Adobe PDF Reader must be installed (see “Install Adobe PDF Reader” on page 35).

- Decline to view the system report and postpone.

4 Your installation settings determine which disks need to be copied during installation. If you are installing directly from the DVDs, follow the Insert Disk prompts as they appear.

If you are installing from a local drive, you won’t insert disks or browse to disk folders – the entire installation will run automatically, based on your installation settings.
If the **OpenLAB CDS Installation Wizard** cannot locate a necessary file (whether on a disk or in a folder), a **Disk or File not found** prompt will appear.

For disks, follow the prompts to:

- **Retry** using the same disk.
- Insert the correct disk (if you made an error), and select **OK**.
- Select **Cancel** to cancel the installation. The system will uninstall any components installed so far.

If a file in a centralized folder cannot be found, you may have to recreate the folder. See “Step 2: Copy DVDs to a Centralized Folder for Installation (Optional)” on page 33 above.

If the installation of any vital application or component fails, the installation will roll back (uninstall). If a failed component can be installed at a later time without affecting basic installation (e.g. ECM API, Driver) the installation will proceed. In this case you will be notified of any failure(s), and that further steps are necessary to fully complete installation.

5 If an installation verification was completed as part of this installation, review the **Software Verification Report**. If the report indicates failure, verify the computer requirements and reinstall the data system. Do not use the system until the Software Verification Report gives a ‘pass’ result.

6 Click **Next** to proceed to the **Installed Features** screen.

7 Click **Finish** to close the installation wizard.
Post Installation Tasks

Enable Non-Http Activation

To make sure that all the net.tcp components are properly initialized, non-http activation must be enabled.

1. Select **Start > Control Panel > Programs > Programs and Features** and click on **Turn Windows features on or off**.

   The **Windows Features** window opens.

2. Expand the **Microsoft .NET Framework 3.5.1** node and select the **Windows Communication Foundation Non-HTTP Activation** check box.

3. Then click **OK**.

Use Network Locations as Enterprise Path

With EZChrom Edition, you can store your projects on an Enterprise Path. If this Enterprise Path is not local, carry out the following procedures.

Create and Share a Folder

1. Create the shared folder. For example, D:\Share1.

2. Right-click the newly created folder and click **Properties**.

3. Select the **Sharing** tab.

4. To set share permissions, click the **Advanced Sharing** button.

5. Select the **Share this folder** check box.

6. Click the **Permissions** button.

7. To give full permission on the folder, click **Everyone** in the group name field and click the **Add...** button.

The created folder is shared.
Set Account for Running the Instrument

1. Go to Start > Programs > Agilent Technologies > OpenLAB CDS EZChrom Edition > AIC and Driver Install Tool.

2. At the OLSS EZChrom Tool — Login screen, type your User Name, Password, and Domain in the fields provided.

3. Select Login.

4. At the OpenLAB Shared Services EZChrom Registrations Functions screen, select the Instrument Service Account tab.

5. Type the Service Account Credentials in the fields provided:
   - User name
   - Password
   - Domain

   The user specified for this service account must be set as a local administrator.

6. Select Store.

7. Close the tool.
What to do Next

The basic installation of the data system software is complete.

There is a 60-day Startup License for this system, and the expiration period starts with your first launch of an application.

To request and download your final software license, and add the license file to your system, see the Software License Installation Guide.

After you have acquired and installed your final software license, you will continue to prepare your data system for operation by end users by configuring projects, users, and instruments. This is accomplished through the OpenLAB CDS Control Panel.

OpenLAB Shared Services Configuration

Refer to the online help for directions on how to do the following tasks.

Configure Security and Storage

1. Launch the OpenLAB Control Panel and navigate to Administration
2. Select System Configuration in the Navigation Window then click Edit System Configuration.
3. Configure the Authentication Provider and Storage to desired settings. When complete, the Control Panel will restart.
4. Log back into the Control Panel with OpenLAB System Administrator credentials.
Configure Users/Groups/Roles

1. Launch the OpenLAB Control Panel and navigate to Administration.
2. Select Users in the Navigation Window. Import/Create Users that will have access to the OpenLAB CDS Workstation.
3. Select Groups in the Navigation Window. Import or Create Groups that will have access to the OpenLAB CDS Workstation.
4. Select Roles in the Navigation Window. Create/edit Roles and assign Users or Groups to those Roles.

Configure License Server

1. Select Licenses in the navigation window. Add a valid license file or server to activate the OpenLAB CDS Workstation Software.

Configure Instruments

1. Launch the OpenLAB Control Panel and navigate to Instruments.
2. Create and configure an Instrument.
3 Install the Software
What to do Next
This chapter describes the syntax and parameters for an installation or uninstallation in command line mode.
About Scripted Installation

The OpenLAB CDS Master Installer supports a command line mode for installation, the so-called *scripted installation*. This mode supports installation, upgrade, repair, and uninstallation. You can execute scripted installations either manually or as part of software management systems such as LANDesk or HP CM. With the corresponding parameter (-q), the scripted installation is completely UI-less.
Export as XML

The Master Installer supports a feature to export the installation parameters into an XML file which you can then use for the scripted installation.

This feature is also supported for upgrade and repair. However, for these cases the exported installation XML file is not appropriate. For scripted repair and upgrade, you must prepare specific XML files using the respective Master Installer wizards.

1. Launch the OpenLab CDS Installation Wizard.

2. Follow the instructions as described under Install the Software in this manual.

3. When you have reached the Summary screen, click the icon on the top right corner to export the installation parameters to XML. Save the file on a physical drive.

**NOTE**
Installation file and XML file must not be in the same file path.

You can now use the XML file for the scripted installation.
Parameters and Return Codes

Parameters

You can call Agilent.OpenLAB.CDSInstaller.exe in command line mode with the following parameters:

- `-i`
  Installation, upgrade or repair
- `-u`
  Uninstallation
- `-q`
  Silent mode — no installation or uninstallation wizard will be shown.
- `-reboot`
  Reboot automatically after successful installation, repair, upgrade, or uninstallation. The system will reboot if the return code is either 0 or 17.

A warning message will be shown in the command prompt 10 min before the system is rebooted. In addition, a Windows dialog opens 2 min before reboot.

- `KeepComponents`
  Optional parameter for the uninstallation process, which can contain one or more shared components that should stay on your system. Without this parameter, all OpenLAB CDS components will be removed from your system. To keep certain shared components, list the corresponding IDs from the table below in double quotes and separated by comma.

<table>
<thead>
<tr>
<th>Component Name</th>
<th>Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software Verification Tool</td>
<td>IQT</td>
</tr>
<tr>
<td>Microsoft SQL Server</td>
<td>SQLServer</td>
</tr>
<tr>
<td>IO Library</td>
<td>IOLibraries</td>
</tr>
</tbody>
</table>
• `ConfigurationXML="<ConfigurationXMLFilePath>"`

The XML file contains all required inputs of the Master Installer to install, upgrade, or repair a certain topology (see “Export as XML” on page 49). Replace `<ConfigurationXMLFilePath>` with the correct file path and XML file name.

**NOTE**
Do not enter a blank before or after the equals (=) sign. The scripted installation and uninstallation mode will not work as expected.

---

**Return Codes**

After installation, uninstallation, upgrade, or repair in the command line mode, the system will return a number code which is explained below.

**Table 3** Return codes

<table>
<thead>
<tr>
<th>Error/Return Code</th>
<th>Return value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown (default)</td>
<td>-1</td>
</tr>
<tr>
<td>Success</td>
<td>0</td>
</tr>
<tr>
<td>CoreComponentFailure</td>
<td>1</td>
</tr>
<tr>
<td>NonCoreComponentFailure</td>
<td>2</td>
</tr>
<tr>
<td>TestConnectivityFailure</td>
<td>3</td>
</tr>
<tr>
<td>ExpectedWindowsInstallerNotInstalled (WI 4.5 missing)</td>
<td>4</td>
</tr>
<tr>
<td>ParameterMismatchError</td>
<td>5</td>
</tr>
<tr>
<td>CannotProceedWithFreshInstallation</td>
<td>6</td>
</tr>
<tr>
<td>CannotProceedWithUpgrade</td>
<td>7</td>
</tr>
<tr>
<td>CannotProceedWithUninstallation</td>
<td>8</td>
</tr>
<tr>
<td>CannotProceedWithRepair</td>
<td>9</td>
</tr>
<tr>
<td>CannotProceedWithReRegistration</td>
<td>10</td>
</tr>
<tr>
<td>ReRegistrationNotSupported</td>
<td>11</td>
</tr>
<tr>
<td>IncompleteTopologyFound</td>
<td>12</td>
</tr>
</tbody>
</table>
### 4. Scripted Installation
Parameters and Return Codes

#### Table 3: Return codes

<table>
<thead>
<tr>
<th>Error/Return Code</th>
<th>Return value</th>
</tr>
</thead>
<tbody>
<tr>
<td>InvalidUNCPath</td>
<td>13</td>
</tr>
<tr>
<td>MissingInstallable</td>
<td>14</td>
</tr>
<tr>
<td>NotAStrongPassword</td>
<td>15</td>
</tr>
<tr>
<td>DowngradeNotSupported</td>
<td>16</td>
</tr>
<tr>
<td>RestartRequired</td>
<td>17</td>
</tr>
<tr>
<td>RegistryCleanupError</td>
<td>18</td>
</tr>
<tr>
<td>InvalidInputXML</td>
<td>19</td>
</tr>
<tr>
<td>InvalidMode</td>
<td>20</td>
</tr>
<tr>
<td>SitePrepFailure</td>
<td>21</td>
</tr>
<tr>
<td>DatabaseConnectionFailed</td>
<td>22</td>
</tr>
<tr>
<td>DotNetFramework4NotInstalled</td>
<td>23</td>
</tr>
<tr>
<td>OLSSConnectionFailed</td>
<td>24</td>
</tr>
<tr>
<td>PDFReaderNotInstalled</td>
<td>25</td>
</tr>
<tr>
<td>AllComponentsInstallationFailed</td>
<td>26</td>
</tr>
<tr>
<td>SomeComponentsInstallationFailed</td>
<td>27</td>
</tr>
<tr>
<td>Failed</td>
<td>28</td>
</tr>
<tr>
<td>AddOnListEmpty</td>
<td>29</td>
</tr>
<tr>
<td>EULANotAccepted</td>
<td>30</td>
</tr>
<tr>
<td>ScriptedNotSupported</td>
<td>31</td>
</tr>
</tbody>
</table>
Installation, Upgrade, or Repair

In installation mode, the OpenLAB CDS Master Installer checks if .Net Framework is present on your system. If not, it will automatically be installed. Select **Accept** to agree with the license agreement.

The Master Installer evaluates the products already installed on your system. Depending on the installed components, the Master Installer will offer one of the following options:

- Start a fresh installation
- Upgrade
- Repair

If a required installable is missing, the Master Installer will create an entry in a log file, and, depending on the component type, will continue or rollback the installation. A corresponding error code will be returned in such scenarios.

**Preparations**

You must have copied all disks to a centralized folder (see “Step 2: Copy DVDs to a Centralized Folder for Installation (Optional)” on page 33). This step is mandatory for scripted installation.

1. Right-click the executable of the command prompt or PowerShell prompt, and run it as administrator.
   
   You will get a return code for the scripted installation only if you start it as administrator.

2. Navigate to the drive where you have saved the disks.
   
   For example: C:\CDS_DVD

3. To start the installation, call Agilent.OpenLab.CDSInstaller.exe with the following syntax:

   ```bash
   Agilent.OpenLab.CDSInstaller.exe -i ConfigurationXML="<path to xml file>" -q -reboot
   ```

   For example:

   ```bash
   Agilent.OpenLab.CDSInstaller.exe -i ConfigurationXML="c:\settings\ConfigurationXML.xml" -q -reboot
   ```

   With this command, you start the installation wizard without a user interface, and automatically reboot the system.
Uninstallation

1. Right-click the executable of the command prompt or Power shell prompt, and run it as administrator.
   You will get a return code for the scripted uninstallation only if you start it as administrator.

2. Navigate to the drive where you have saved the disks.
   For example: C:\CDS_DVD

3. To start the uninstallation, call Agilent.OpenLab.CDSInstaller.exe with the following syntax:

   ```
   Agilent.OpenLab.CDSInstaller.exe -u KeepComponents="<list of components>" -q -reboot
   ```

   For Example:

   ```
   Agilent.OpenLab.CDSInstaller.exe -u KeepComponents="IQT,IOLibraries" -q -reboot
   ```

   With the KeepComponents parameter, you can specify a list of shared components that you want to keep on the system (see “Parameters” on page 50). With the command given in the example, the OpenLAB CDS components Software Verification Tool (IQT) and IO Library (IOLibraries) will be kept.

Logging and Tracing

All exceptions, errors and information messages are logged in the following locations:

- During installation, upgrade, or repair: under <BaseInstallDirectory>\Logs
- During uninstallation: under <User's Temp>\<Company Name>\Logs\<Log folder>\<Wizard Name>.txt
5 Optional Procedures

Install OpenLAB Data Analysis as Add-on or Stand-alone Application 56
Install Additional Software and Drivers 59
Run a Software Verification after Software Installation 60
Upgrade OpenLAB CDS Workstation to Latest Version 61
  License Upgrade 61
  Upgrade a ChemStation Edition Workstation 62
  Upgrading an EZChrom Edition Workstation 63
Transform a Workstation to a Networked Workstation 65

This chapter describes the installation of OpenLAB Data Analysis as an add-on or standalone application. It also contains information on the Additional Drivers and Software wizard, the Software Verification Tool, and the upgrade of an OpenLAB CDS Workstation.
Install OpenLAB Data Analysis as Add-on or Stand-alone Application

If you have not installed OpenLAB Data Analysis together with OpenLAB CDS, you can install OpenLAB Data Analysis as an add-on to OpenLAB CDS or as a stand-alone application.

**NOTE** OpenLAB Data Analysis is not supported for installations with ECM or Data Store as central data storage.

1. Run the Master Installer.
2. From the **Master Installer** screen, select **Installation**.
3. Select **OpenLAB Data Analysis**.
4. The **OpenLAB Data Analysis Installation Wizard** opens. Read the terms of the **License Agreement**. The Master Installer provides a printable PDF of the license agreement under the **Resources** option of the main menu.
5. Select **I agree with the terms and conditions**. You cannot proceed with installation unless you agree to these terms.
6. Click **Next** to proceed to the **Installation Folder** screen.
7. If you already have installed OpenLAB CDS on your PC, OpenLAB Data Analysis will be installed as an add-on.
   a. To run an installation verification as part of this installation, select **Run Software Verification**. The Software Verification Tool provides documentary evidence that your system has been built and installed correctly. You can run the Software Verification Tool at a later time if you prefer.
   b. Click **Next** to proceed to the **OpenLAB Shared Services Settings for Registration** screen.
   c. Enter the server name and authentication provider.
d  Click **Test Connection** ... to run a connectivity check.

The system will display a **Connection succeeded** message if the check is successful.

e  Continue with step 10.

8  If you have not installed OpenLAB CDS on your PC, OpenLAB Data Analysis will be installed as a stand-alone application.

a  You can use the default folder, type a new folder name or browse to the directory where you want to install OpenLAB Data Analysis.

b  To run an installation verification as part of this installation, select **Run Software Verification**. The Software Verification Tool provides documentary evidence that your system has been built and installed correctly. You can run the Software Verification Tool at a later time if you prefer.

c  Click **Next**.

d  Select the required installation type.

9  If you have selected **Networked Workstation**:

a  Click **Next**.

b  In the **OpenLAB Shared Services Settings for Registration** screen complete the **Server name** field.

c  Select the authentication provider as set in the OpenLAB Control Panel.

d  When you type in the **Server name**, the **Test Connection**... button will be activated. You can test connectivity for this server before completing the rest of this screen.

e  Select **Next**. The system will perform a connectivity check for the server.

**NOTE**

An installation on a networked workstation is only supported in combination with OpenLAB CDS EZChrom Edition. For this type of installation, only the Enterprise path without Advanced File Security (AFS) is supported as storage.
If the connectivity test fails, verify that the server name was entered correctly, without spaces, and select Next to run the test again. If the test is still unsuccessful, you can:

- Enter a new server and try another test.
- Call internal support for assistance if you cannot connect to a server.

When a connectivity test has run successfully, the system will proceed to the Additional items screen.

1. In the Additional Items screen, EZChrom Enterprise Path is selected.

10. Click Next to proceed to the Summary screen.

11. Click Start to begin installation.

12. When the installation is finished, click Next to proceed to the Installed Features screen.

13. Click Finish to close the installation wizard.
Install Additional Software and Drivers

OpenLAB CDS offers a wizard to help you installing additional software, such as drivers for third-party instruments. To open the wizard, go to Start > All programs > Agilent Technologies > OpenLAB > OpenLAB Additional Software and Drivers. Follow the wizard to install the required software.

Prepare Network Drives

If the additional software is located on a network drive, you must prepare the network drive to make it accessible by the wizard. Without this preparation, Windows security prevents the wizard from accessing those drives.

1 Map the drive to a letter.
   For example, map the drive as Z: using the shared path "\\
   <machine-name>\OpenLABCDS".
   This maps the drive for the logged-in user.

2 Open the command prompt in elevated mode (run as administrator), and map the drive using the net use command.
   For example,
   net use Z: "\\<machine-name>\OpenLABCDS"
   This maps the drive for the local administrator account. The mapped drive is now visible to both logged-in user and administrator, and can be selected in the wizard.

Configure Third-Party Instruments

Run a Software Verification after Software Installation

The Software Verification Tool provides documentary evidence that your system has been built and installed correctly, and that all design specifications have been met.

1 Using your Windows operating system, go to **Start > All Programs > Agilent Technologies > Software Verification Tool**.

2 Select **Qualify**.
   The system will run the application and generate a Software Verification Report.

3 If the report indicates failure, verify the computer requirements and reinstall the data system.
   Do not use the system until the Software Verification Report gives a ‘pass’ result.
Upgrade OpenLAB CDS Workstation to Latest Version

License Upgrade

If you are upgrading from a version older than A.02.01, you will need to get a new license to upgrade to the new version of the software. We strongly recommend upgrading your workstation licenses before upgrading the core software. Standalone workstations which are upgraded to the new core software version, without a new workstation license, will not work until the new workstation licenses are added to the OpenLAB Control Panel.

If you are under SMA subscription, proceed as follows to upgrade your licenses:

1. Log into the Agilent Electronic Software and License Delivery (https://agilent.subscribenet.com/).

2. Navigate to Manage Licenses by Host, and search for the machine hosting your workstation. Alternatively, select the machine from the drop-down list.

3. Click Upgrade All to upgrade all licenses on this host to the most recent version. Confirm the upgrade on the next screen.

   This upgrades the license file to the most current version. SubscribeNet will send you an email with a new license file.

4. Put the new license file on your system.

   If you have multiple single Workstations, repeat this step for each individual workstation.

5. Download the most recent version of OpenLAB CDS software from SubscribeNet and install it.
Upgrade a ChemStation Edition Workstation

An OpenLAB CDS A.01.xx or A.02.01 ChemStation Edition Workstation can directly be upgraded to OpenLAB CDS A.02.02.

NOTE

The settings in the ChemStation Administration Tool may change during the update process. After the upgrade, check if the settings in the ChemStation Administration Tool still match your original system settings before the upgrade.

1. From the Master Installer Planning screen, switch to the Installation screen.
2. Select OpenLAB CDS Installation. If OpenLAB CDS is already installed, this automatically opens the OpenLAB CDS Upgrade Wizard.
3. When upgrading from a version prior to OpenLAB CDS A.02.01, the workstation license must be upgraded see “License Upgrade” on page 61. Acknowledge that the license has been upgraded and click Next to continue.
4. Select I agree with the terms and conditions. You cannot proceed with the upgrade unless you agree to these terms. Click Next.
5. If an Authentication Provider has been configured: Enter the username and password of a user with system administration privileges in the OpenLAB Shared Services Settings for Registration screen. Click Next.
6. In the Summary screen of the Upgrade Wizard, the components for the upgrade are listed. Click Start to proceed with the upgrade.

If an error occurs during the upgrade, an error message appears.
After the upgrade is finished, select **Finish** to close the OpenLAB CDS Upgrade Wizard.

Existing instrument configuration can remain unchanged after the upgrade.

**NOTE**
If you reconfigure existing instruments: For 35900 ADC instruments, do **not** switch from classic drivers to RC.NET drivers. 35900 ADC may no longer write data afterwards.

After an upgrade of a ChemStation, configuration files for every instrument should be deleted.

1. Open the Windows Explorer on the instrument controller (Stand-alone Workstation, Networked Workstation, or AIC).
2. Navigate to the ChemStation installation folder.
   By default, this folder is named C:\Chem32.
3. Make sure all online and offline ChemStation sessions are closed.
4. Go into each of the existing instrument folders (Chem32\1, Chem32\2, ... ) and delete the files with the names Config.reg and Conf_off.reg.
   Do not delete any other files.

### Upgrading an EZChrom Edition Workstation

**Upgrading From A.01.01**

Uninstall OpenLAB CDS A.01.01, then install A.02.02.

**Upgrading From A.01.02**

First upgrade your application to OpenLAB CDS A.01.03. In a second step, upgrade to A.02.02.
Upgrading From A.01.03 or Higher

You can upgrade to OpenLAB CDS A.02.02 in one step, using the OpenLAB CDS Upgrade Wizard in the Master Installer.

The settings in the ChemStation Administration Tool may change during the update process. After the upgrade, check if the settings in the ChemStation Administration Tool still match your original system settings before the upgrade.

1. From the Master Installer Planning screen, switch to the Installation screen.

2. Select OpenLAB CDS Installation.
   
   If OpenLAB CDS is already installed, this automatically opens the OpenLAB CDS Upgrade Wizard.

3. When upgrading from a version prior to OpenLAB CDS A.02.01, the workstation license must be upgraded see “License Upgrade” on page 61.

   Acknowledge that the license has been upgraded and click Next to continue.

4. Select I agree with the terms and conditions. You cannot proceed with the upgrade unless you agree to these terms. Click Next.

5. If an Authentication Provider has been configured: Enter the username and password of a user with system administration privileges in the OpenLAB Shared Services Settings for Registration screen. Click Next.

6. In the Summary screen of the Upgrade Wizard, the components for the upgrade are listed. Click Start to proceed with the upgrade.

   If an error occurs during the upgrade, an error message appears.

7. After the upgrade is finished, select Finish to close the OpenLAB CDS Upgrade Wizard.

   Existing instrument configuration can remain unchanged after the upgrade.

   **NOTE**

   If you reconfigure existing instruments: For 35900 ADC instruments, do not switch from classic drivers to RC.NET drivers. 35900 ADC may no longer write data afterwards.
Transform a Workstation to a Networked Workstation

With Networked Workstations, you use a separate OpenLAB Shared Services server to control the system. You can access all information provided by OpenLAB Shared Services from any Networked Workstation. For example, you can see on each workstation which instruments are available and which status (Online, Offline, Error, In Run, Not Ready, etc.) the instruments currently have. Also licenses and user accounts are managed centrally on the OpenLAB Shared Services server.

**NOTE**

- You must already have installed an OpenLAB Shared Services server. See *Networked and Distributed System Installation and Configuration* (CDS_NWSDS-Installation.pdf on disk 1).

- Make sure that the versions of Workstation and OpenLAB Shared Services Server are identical. If not, upgrade your Workstation before doing the transformation. See “Upgrade OpenLAB CDS Workstation to Latest Version” on page 61.

  For more information on temporary support of mixed version systems during an upgrade phase, refer to the *OpenLAB CDS Administration Guide* (CDS_Admin.pdf on Disk 1).

**CAUTION**

Conflict of multiple instruments having the same name

Check if the instruments used on the Workstation have a name that already exists in the network. If this is the case, or if you are not sure:

- Before starting the transformation: Copy the data, methods, and sequences from the relevant instrument to a local backup folder. Then delete the instrument on the Workstation.

- After the transformation, configure a new instrument, and copy back the data from the local folder.
5  Optional Procedures
Transform a Workstation to a Networked Workstation

1. From the OpenLAB CDS Master Installer screen, select **Maintenance**.

2. Select **Transformation of an OpenLAB Standalone Workstation into a Networked Workstation**.

3. Enter the server name and the authentication service used by the server.
   If the server requires authentication, you will be asked for the credentials of an OpenLAB Shared Services administrator.

4. Start the transformation.
   All instruments will be registered on the OpenLAB Shared Services Server.
6
Uninstall the Software

About Uninstallation 68
Run the Master Installer 69
Run the OpenLAB CDS Uninstallation Wizard 70

This chapter contains information on the uninstallation by using the OpenLAB CDS Uninstallation Wizard. It also describes post uninstallation tasks that are essential if you plan to reinstall ChemStation on the same computer.
About Uninstallation

If the Master Installer was not used for installation, any manually installed additional software such as Headspace, PAL, or third party drivers must be uninstalled using the Windows Control Panel before the OpenLAB CDS can be uninstalled.

Like the installation, the uninstallation of OpenLAB CDS is automated by the OpenLAB CDS Master Installer.

For your convenience, the Master Installer uses the same user interfaces for the software uninstallation of all OpenLAB CDS configurations (standalone or networked workstation). The **OpenLAB CDS Uninstallation Wizard** under the **Maintenance** section of the Master Installer guides you through the uninstallation steps.

OpenLAB Data Analysis can be uninstalled separately (see *OpenLAB Data Analysis - Getting Started*).

**NOTE**

Do not use the Windows uninstallation tool for uninstalling OpenLAB CDS.
Run the Master Installer

To run the Master Installer on your workstation choose one of the following approaches:

- To run the uninstallation from disk, insert the OpenLAB CDS Installation disk (Disk 1).
  Autostart will automatically run Agilent.OpenLABCDSSetupFromDVD.exe and display the installer Planning screen.

- For the portable data storage device approach, insert the device in a computer USB port, navigate to \Disk1 and run Setup.bat to proceed to the Planning screen.

- For the share file approach, copy the contents to the local drive and navigate to the respective share file folder. Then navigate to \Disk1 and run Setup.bat to proceed to the Planning screen.
Run the OpenLAB CDS Uninstallation Wizard

1. From the Master Installer Planning screen, select Maintenance from the side bar menu.
2. Select OpenLAB CDS Uninstallation.
   The OpenLAB CDS Uninstallation Wizard opens.
3. In the Shared Components screen, check the Uninstall Software Verification check box.
   Note: Software Verification Tool needs to be uninstalled if you wish to re-install OpenLAB CDS at a later time
4. In the Summary screen under Uninstallation of OpenLAB CDS Components, there is a list of the components you want to uninstall.
5. Select Start to start the uninstallation.
   If you want to abort the uninstallation, select Cancel. If you want to change any settings, select Back.
   All listed components are automatically uninstalled, one after another.
6. When the uninstallation has finished, click Finish to close the uninstallation wizard.
This installation guide is designed to help system administrators install the Agilent OpenLAB Chromatography Data System (CDS) to individual workstations quickly and correctly.